home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-libs / ss-1.38 / ss-1.38.ebuild < prev    next >
Text File  |  2005-10-13  |  2KB  |  62 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.38.ebuild,v 1.15 2005/09/25 22:16:31 vapier Exp $
  4.  
  5. inherit eutils flag-o-matic toolchain-funcs
  6.  
  7. DESCRIPTION="Subsystem command parsing library"
  8. HOMEPAGE="http://e2fsprogs.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
  14. IUSE="nls"
  15.  
  16. RDEPEND="~sys-libs/com_err-${PV}"
  17. DEPEND="${RDEPEND}
  18.     nls? ( sys-devel/gettext )"
  19.  
  20. S=${WORKDIR}/e2fsprogs-${PV}
  21.  
  22. src_unpack() {
  23.     unpack ${A}
  24.     cd "${S}"
  25.     epatch "${FILESDIR}"/${PN}-1.38-locale.patch
  26.     epatch "${FILESDIR}"/${PN}-1.37-makefile.patch
  27.     export LDCONFIG=/bin/true
  28.     export CC=$(tc-getCC)
  29.     export STRIP=/bin/true
  30. }
  31.  
  32. src_compile() {
  33.     local libtype
  34.     case ${USERLAND} in
  35.         Darwin) libtype=bsd;;
  36.         *)      libtype=elf;;
  37.     esac
  38.     mkdir -p lib/{blkid,e2p,et,ext2fs,ss,uuid}/{checker,elfshared,pic,profiled} #102412
  39.     econf \
  40.         --enable-${libtype}-shlibs \
  41.         --with-ldopts="${LDFLAGS}" \
  42.         $(use_enable nls) \
  43.         || die
  44.     emake -C lib/ss COMPILE_ET=compile_et || die "make ss failed"
  45. }
  46.  
  47. src_test() {
  48.     make -C lib/ss check || die "make check failed"
  49. }
  50.  
  51. src_install() {
  52.     dodir /usr/share/man/man1
  53.     make -C lib/ss DESTDIR="${D}" install || die
  54.  
  55.     # Move shared libraries to /lib/, install static libraries to /usr/lib/,
  56.     # and install linker scripts to /usr/lib/.
  57.     dodir /$(get_libdir)
  58.     mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "move .so"
  59.     dolib.a lib/libss.a || die "dolib.a"
  60.     gen_usr_ldscript libss.so
  61. }
  62.